# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d{2}\/\d{2}\/\d{4}),\s(\d(?:\d)?:\d{2})\s-\s([^:]*):\s(.*?)(?=\s*\d{2}\/|\$)"
test_str = ("29/09/2018, 22:29 - מילה: העבירו בקבוצות שלכם לחברים, \n"
"הודעה מרופא *מאיכילוב* -\n"
"אני מחפש גבר בעל סוג דם AB+ בלבד,\n"
"לתרומת דם, כדוריות לבנות, לילד הנלחם על חייו - לוקמיה. \n"
"הילד על הקצה ממש, \n"
"תפעילו את קשריכם החברתיים, \n"
"בואו ננסה לעשות טוב.\n"
"תודה.\n"
"ד\"ר אילן. +972 54-440-3854\n"
"30/09/2018, 07:37 - ורד: ביום שלישי הקרוב .משעה 8-17 תחסם כניסה ג' .\n\n"
"גם בתוך הדירות אסור יהיה להשאר.\n"
"תודה על שיתוף הפעולה .נא ליידע את הדיירים .\n"
"חג שמח\n"
"26/08/2019, 20:28 - +972 54-477-1234: ערב טוב \n"
"לכל מי שטרם העביר לועד הבית את חלקו בתשלום לעורך הדין אנא עשו זאת ניתן להעביר מחר .\n"
"26/08/2019, 20:32 - יורם כהן(כניסה ב'): א.כמה התשלום הראשון . \n"
"ב. אפשר מחר בפגישה לקבל מצב חשבון של הועד\n"
"04/09/2019, 12:46 - +972 54-368-7925: שלחתי לכם מייל הבוקר\n"
"04/09/2019, 12:46 - +972 54-477-9495: מחר ההתקנה\n"
"04/09/2019, 12:47 - +972 54-477-4395: IMG-20190904-WA00353.jpg (file attached)\n"
"04/09/2019, 12:48 - +972 53-973-7566's security code changed. Tap for more info.\n"
"04/09/2019, 12:49 - סיגל: תודה\n"
"04/09/2019, 13:20 - +972 54-480-9365: הי זה כולל מנעול רב בריח עם מפתחות חדשים?..\n"
"04/09/2019, 13:57 - +972 54-477-8795: אני מניח שכן\n\n")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.