import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{2}\\/\\d{2}\\/\\d{4}),\\s(\\d(?:\\d)?:\\d{2})\\s-\\s([^:]*):\\s(.*?)(?=\\s*\\d{2}\\/|\\$)";
final String string = "29/09/2018, 22:29 - מילה: העבירו בקבוצות שלכם לחברים, \n"
+ "הודעה מרופא *מאיכילוב* -\n"
+ "אני מחפש גבר בעל סוג דם AB+ בלבד,\n"
+ "לתרומת דם, כדוריות לבנות, לילד הנלחם על חייו - לוקמיה. \n"
+ "הילד על הקצה ממש, \n"
+ "תפעילו את קשריכם החברתיים, \n"
+ "בואו ננסה לעשות טוב.\n"
+ "תודה.\n"
+ "ד\"ר אילן. +972 54-440-3854\n"
+ "30/09/2018, 07:37 - ורד: ביום שלישי הקרוב .משעה 8-17 תחסם כניסה ג' .\n\n"
+ "גם בתוך הדירות אסור יהיה להשאר.\n"
+ "תודה על שיתוף הפעולה .נא ליידע את הדיירים .\n"
+ "חג שמח\n"
+ "26/08/2019, 20:28 - +972 54-477-1234: ערב טוב \n"
+ "לכל מי שטרם העביר לועד הבית את חלקו בתשלום לעורך הדין אנא עשו זאת ניתן להעביר מחר .\n"
+ "26/08/2019, 20:32 - יורם כהן(כניסה ב'): א.כמה התשלום הראשון . \n"
+ "ב. אפשר מחר בפגישה לקבל מצב חשבון של הועד\n"
+ "04/09/2019, 12:46 - +972 54-368-7925: שלחתי לכם מייל הבוקר\n"
+ "04/09/2019, 12:46 - +972 54-477-9495: מחר ההתקנה\n"
+ "04/09/2019, 12:47 - +972 54-477-4395: IMG-20190904-WA00353.jpg (file attached)\n"
+ "04/09/2019, 12:48 - +972 53-973-7566's security code changed. Tap for more info.\n"
+ "04/09/2019, 12:49 - סיגל: תודה\n"
+ "04/09/2019, 13:20 - +972 54-480-9365: הי זה כולל מנעול רב בריח עם מפתחות חדשים?..\n"
+ "04/09/2019, 13:57 - +972 54-477-8795: אני מניח שכן\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}