const regex = /^D(\d*)-(\d*)-(\d*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^D(\\d*)-(\\d*)-(\\d*)$', 'gm')
const str = `!Type:Bank
D2023-11-20
T-2 043.51
PCARTE 19/11/23 LEROY MERLIN
LBricolage et jardinage
^
`;
const subst = `D$3/$2/$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);