re = /^D(\d*)-(\d*)-(\d*)$/m
str = '!Type:Bank
D2023-11-20
T-2 043.51
PCARTE 19/11/23 LEROY MERLIN
LBricolage et jardinage
^
'
subst = 'D$3/$2/$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result