// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^D(\d*)-(\d*)-(\d*)$").unwrap();
let string = "!Type:Bank
D2023-11-20
T-2 043.51
PCARTE 19/11/23 LEROY MERLIN
LBricolage et jardinage
^
";
let substitution = "D$3/$2/$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}