#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(([\w\.]+)(\.[^/\n]+)\/?(.*\/?)*)" & @CRLF & _
""
Local $sString = "google.map.com" & @CRLF & _
"google.com" & @CRLF & _
"youtube.com/die_bro" & @CRLF & _
"y0ut_ube.com" & @CRLF & _
"tmall.com" & @CRLF & _
"tmall.com/yo/got/mail" & @CRLF & _
"facebook.com" & @CRLF & _
"facebook.com" & @CRLF & _
"baidu.com" & @CRLF & _
"baidu.com" & @CRLF & _
"qq.com" & @CRLF & _
"qq.com" & @CRLF & _
"sohu.com" & @CRLF & _
"sohu.com" & @CRLF & _
"login.tmall.com" & @CRLF & _
"login.tmall.com" & @CRLF & _
"taobao.com" & @CRLF & _
"taobao.com" & @CRLF & _
"yahoo.com" & @CRLF & _
"yahoo.com" & @CRLF & _
"JD.com" & @CRLF & _
"JD.com" & @CRLF & _
"JD.com" & @CRLF & _
"JD.com" & @CRLF & _
"jd.com" & @CRLF & _
"jd.com" & @CRLF & _
"amazon.com" & @CRLF & _
"amazon.com" & @CRLF & _
"sina.com" & @CRLF & _
"sina.com" & @CRLF & _
"weibo.com" & @CRLF & _
"weibo.com" & @CRLF & _
"pages.tmall.com" & @CRLF & _
"pages.tmall.com" & @CRLF & _
"live.com" & @CRLF & _
"live.com" & @CRLF & _
"reddit.com" & @CRLF & _
"reddit.com" & @CRLF & _
"netflix.com" & @CRLF & _
"netflix.com" & @CRLF & _
"xinhuanet.com" & @CRLF & _
"xinhuanet.com" & @CRLF & _
"Okezone.com" & @CRLF & _
"Okezone.com" & @CRLF & _
"Okezone.com" & @CRLF & _
"Okezone.com" & @CRLF & _
"okezone.com" & @CRLF & _
"okezone.com" & @CRLF & _
"blogspot.com" & @CRLF & _
"blogspot.com" & @CRLF & _
"office.com" & @CRLF & _
"office.com" & @CRLF & _
"microsoft.com" & @CRLF & _
"microsoft.com" & @CRLF & _
"vk.com" & @CRLF & _
"vk.com" & @CRLF & _
"csdn.net" & @CRLF & _
"csdn.net" & @CRLF & _
"instagram.com" & @CRLF & _
"instagram.com" & @CRLF & _
"alipay.com" & @CRLF & _
"alipay.com" & @CRLF & _
"bing.com" & @CRLF & _
"bing.com" & @CRLF & _
"google.com" & @CRLF & _
"google.com" & @CRLF & _
"bongacams.com" & @CRLF & _
"bongacams.com" & @CRLF & _
"microsoftonline.com" & @CRLF & _
"microsoftonline.com" & @CRLF & _
"livejasmin.com" & @CRLF & _
"livejasmin.com" & @CRLF & _
"tribunnews.com" & @CRLF & _
"tribunnews.com" & @CRLF & _
"twitter.com" & @CRLF & _
"twitter.com" & @CRLF & _
"stackoverflow.com" & @CRLF & _
"stackoverflow.com" & @CRLF & _
"naver.com" & @CRLF & _
"naver.com" & @CRLF & _
"Amazon.com" & @CRLF & _
"Amazon.com" & @CRLF & _
"Amazon.com" & @CRLF & _
"Amazon.com" & @CRLF & _
"aliexpress.com" & @CRLF & _
"aliexpress.com" & @CRLF & _
"ebay.com" & @CRLF & _
"ebay.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")