import re
regex = re.compile((r"(([\w\.]+)(\.[^/\n]+)\/?(.*\/?)*)\n"), flags=re.MULTILINE)
test_str = ("google.map.com\n"
"google.com\n"
"youtube.com/die_bro\n"
"y0ut_ube.com\n"
"tmall.com\n"
"tmall.com/yo/got/mail\n"
"facebook.com\n"
"facebook.com\n"
"baidu.com\n"
"baidu.com\n"
"qq.com\n"
"qq.com\n"
"sohu.com\n"
"sohu.com\n"
"login.tmall.com\n"
"login.tmall.com\n"
"taobao.com\n"
"taobao.com\n"
"yahoo.com\n"
"yahoo.com\n"
"JD.com\n"
"JD.com\n"
"JD.com\n"
"JD.com\n"
"jd.com\n"
"jd.com\n"
"amazon.com\n"
"amazon.com\n"
"sina.com\n"
"sina.com\n"
"weibo.com\n"
"weibo.com\n"
"pages.tmall.com\n"
"pages.tmall.com\n"
"live.com\n"
"live.com\n"
"reddit.com\n"
"reddit.com\n"
"netflix.com\n"
"netflix.com\n"
"xinhuanet.com\n"
"xinhuanet.com\n"
"Okezone.com\n"
"Okezone.com\n"
"Okezone.com\n"
"Okezone.com\n"
"okezone.com\n"
"okezone.com\n"
"blogspot.com\n"
"blogspot.com\n"
"office.com\n"
"office.com\n"
"microsoft.com\n"
"microsoft.com\n"
"vk.com\n"
"vk.com\n"
"csdn.net\n"
"csdn.net\n"
"instagram.com\n"
"instagram.com\n"
"alipay.com\n"
"alipay.com\n"
"bing.com\n"
"bing.com\n"
"google.com\n"
"google.com\n"
"bongacams.com\n"
"bongacams.com\n"
"microsoftonline.com\n"
"microsoftonline.com\n"
"livejasmin.com\n"
"livejasmin.com\n"
"tribunnews.com\n"
"tribunnews.com\n"
"twitter.com\n"
"twitter.com\n"
"stackoverflow.com\n"
"stackoverflow.com\n"
"naver.com\n"
"naver.com\n"
"Amazon.com\n"
"Amazon.com\n"
"Amazon.com\n"
"Amazon.com\n"
"aliexpress.com\n"
"aliexpress.com\n"
"ebay.com\n"
"ebay.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")