// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(([\w\.]+)(\.[^/\n]+)\/?(.*\/?)*)
").unwrap();
let string = "google.map.com
google.com
youtube.com/die_bro
y0ut_ube.com
tmall.com
tmall.com/yo/got/mail
facebook.com
facebook.com
baidu.com
baidu.com
qq.com
qq.com
sohu.com
sohu.com
login.tmall.com
login.tmall.com
taobao.com
taobao.com
yahoo.com
yahoo.com
JD.com
JD.com
JD.com
JD.com
jd.com
jd.com
amazon.com
amazon.com
sina.com
sina.com
weibo.com
weibo.com
pages.tmall.com
pages.tmall.com
live.com
live.com
reddit.com
reddit.com
netflix.com
netflix.com
xinhuanet.com
xinhuanet.com
Okezone.com
Okezone.com
Okezone.com
Okezone.com
okezone.com
okezone.com
blogspot.com
blogspot.com
office.com
office.com
microsoft.com
microsoft.com
vk.com
vk.com
csdn.net
csdn.net
instagram.com
instagram.com
alipay.com
alipay.com
bing.com
bing.com
google.com
google.com
bongacams.com
bongacams.com
microsoftonline.com
microsoftonline.com
livejasmin.com
livejasmin.com
tribunnews.com
tribunnews.com
twitter.com
twitter.com
stackoverflow.com
stackoverflow.com
naver.com
naver.com
Amazon.com
Amazon.com
Amazon.com
Amazon.com
aliexpress.com
aliexpress.com
ebay.com
ebay.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}