const regex = /^(?!fashion tv)[^\n\r]+\r?\nhttps?:\/\/[^\n\r]+\r?\n?/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!fashion tv)[^\\n\\r]+\\r?\\nhttps?:\\\/\\\/[^\\n\\r]+\\r?\\n?', 'gmi')
const str = `Diva Universal (Россия)
http://буквенно-циферный url
Familia Domashniy
http://буквенно-циферный url
Fashion TV
http://буквенно-циферный url
Fashion TV HD
http://буквенно-циферный url
Fashion TV 3 HD
http://буквенно-циферный url
Fashion TV 9 HD
http://буквенно-циферный url
Fine Living
http://буквенно-циферный url
Fine Living Europe
http://буквенно-циферный url
Fine Living Network
http://буквенно-циферный url
Food Network
http://буквенно-циферный url
Food Network HD
http://буквенно-циферный url`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);