import Foundation
let pattern = #"^(?!fashion tv)[^\n\r]+\r?\nhttps?:\/\/[^\n\r]+\r?\n?"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Diva Universal (Россия)
http://буквенно-циферный url
Familia Domashniy
http://буквенно-циферный url
Fashion TV
http://буквенно-циферный url
Fashion TV HD
http://буквенно-циферный url
Fashion TV 3 HD
http://буквенно-циферный url
Fashion TV 9 HD
http://буквенно-циферный url
Fine Living
http://буквенно-циферный url
Fine Living Europe
http://буквенно-циферный url
Fine Living Network
http://буквенно-циферный url
Food Network
http://буквенно-циферный url
Food Network HD
http://буквенно-циферный url
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)