$re = '/^(?!fashion tv)[^\n\r]+\r?\nhttps?:\/\/[^\n\r]+\r?\n?/mi';
$str = 'Diva Universal (Россия)
http://буквенно-циферный url
Familia Domashniy
http://буквенно-циферный url
Fashion TV
http://буквенно-циферный url
Fashion TV HD
http://буквенно-циферный url
Fashion TV 3 HD
http://буквенно-циферный url
Fashion TV 9 HD
http://буквенно-циферный url
Fine Living
http://буквенно-циферный url
Fine Living Europe
http://буквенно-циферный url
Fine Living Network
http://буквенно-циферный url
Food Network
http://буквенно-циферный url
Food Network HD
http://буквенно-циферный url';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;