import re
regex = re.compile(r"(is_granted\()\[(\W.+?)\]", flags=re.MULTILINE)
test_str = "\"expr(not is_granted(['SITE_PERMISSION_VIEW_AUDIT_ANSWER_OPTIONS']) and not is_granted(['SITE_PERMISSION_CREATE_AUDITS']) and not is_granted(['SITE_PERMISSION_CREATE_AUDIT_TEMPLATES']))\","
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)