// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(is_granted\()\[(\W.+?)\]").unwrap();
let string = "\"expr(not is_granted(['SITE_PERMISSION_VIEW_AUDIT_ANSWER_OPTIONS']) and not is_granted(['SITE_PERMISSION_CREATE_AUDITS']) and not is_granted(['SITE_PERMISSION_CREATE_AUDIT_TEMPLATES']))\",";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}