using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^#~*]\S[^\n]*)\s*";
string input = @"# Тестирование строки
Это строка не участвует в выражении
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}