re = /([^#~*]\S[^\n]*)\s*/
str = '# Тестирование строки
Это строка не участвует в выражении
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end