$re = '/([^#~*]\S[^\n]*)\s*/';
$str = '# Тестирование строки
Это строка не участвует в выражении
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);