using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" \s*\(\p{Sc}\d[.\d]*\)";
string input = @" TEXT (text) (€10.00)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}