package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(` \s*\(\p{Sc}\d[.\d]*\)`)
var str = ` TEXT (text) (€10.00)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}