using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:[Ss]ub)?(?:-)?(?:paragraph)?(?:s)?(?:\s*\([a-z]\))(?:,\s*(?:\s*\([a-z]\))?)*(?:\s*(?:[,&]|and)\s+?(?:\s*\([a-z]\)+)?)?(?:(?:\s*to)*(?:\s*\([a-z]\)))*(?:\s*of\s*)*)";
string input = @"Sub-Clause 9.12
subparagraphs (a), (b) and (c) of Sub-Clause 4.8
Clause 13
paragraph (b) of Sub-Clause 9.3
SubClauses 9.8, 9.9 and 9.10
sub-paragraph (b) of Sub-Clause 12.1
Sub-Clauses 17.1(b)(ii) and 17.3(b)(ii)
sub-paragraphs (a) to (e) of Sub-Clause 18.1
Sub-Clause 20.1(d)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}