import re
regex = re.compile(r"^(?:(?:[Ss]ub)?(?:-)?(?:paragraph)?(?:s)?(?:\s*\([a-z]\))(?:,\s*(?:\s*\([a-z]\))?)*(?:\s*(?:[,&]|and)\s+?(?:\s*\([a-z]\)+)?)?(?:(?:\s*to)*(?:\s*\([a-z]\)))*(?:\s*of\s*)*)", flags=re.MULTILINE)
test_str = ("Sub-Clause 9.12\n"
"subparagraphs (a), (b) and (c) of Sub-Clause 4.8\n"
"Clause 13\n"
"paragraph (b) of Sub-Clause 9.3\n"
"SubClauses 9.8, 9.9 and 9.10\n"
"sub-paragraph (b) of Sub-Clause 12.1\n"
" \n"
"Sub-Clauses 17.1(b)(ii) and 17.3(b)(ii)\n"
"sub-paragraphs (a) to (e) of Sub-Clause 18.1\n"
"Sub-Clause 20.1(d)\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")