import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:[Ss]ub)?(?:-)?(?:paragraph)?(?:s)?(?:\\s*\\([a-z]\\))(?:,\\s*(?:\\s*\\([a-z]\\))?)*(?:\\s*(?:[,&]|and)\\s+?(?:\\s*\\([a-z]\\)+)?)?(?:(?:\\s*to)*(?:\\s*\\([a-z]\\)))*(?:\\s*of\\s*)*)";
final String string = "Sub-Clause 9.12\n"
+ "subparagraphs (a), (b) and (c) of Sub-Clause 4.8\n"
+ "Clause 13\n"
+ "paragraph (b) of Sub-Clause 9.3\n"
+ "SubClauses 9.8, 9.9 and 9.10\n"
+ "sub-paragraph (b) of Sub-Clause 12.1\n"
+ " \n"
+ "Sub-Clauses 17.1(b)(ii) and 17.3(b)(ii)\n"
+ "sub-paragraphs (a) to (e) of Sub-Clause 18.1\n"
+ "Sub-Clause 20.1(d)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}