use strict;
my $str = 'Item Description Quantity Price Per Total
Various paper supplies 1 269033 USD 269033 USD';
my $regex = qr/(?<=Total\r?\n\r?\n?.+\s+\d+\s+\d+\s+)[A-z]{3}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}