#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((^3\.(0[13578]|1[2])(\.[0-9]{4})|^28\.02\.([0-9]{4}))|(30\.(0[469]|11)(\.[0-9]{4})|^[0-2][0-9]\.(0[13578]|1[02])(\.[0-9]{4})))$"
Local $sString = "26.01.2020" & @CRLF & _
"10.12.2020" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")