const regex = /((^3\.(0[13578]|1[2])(\.[0-9]{4})|^28\.02\.([0-9]{4}))|(30\.(0[469]|11)(\.[0-9]{4})|^[0-2][0-9]\.(0[13578]|1[02])(\.[0-9]{4})))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((^3\\.(0[13578]|1[2])(\\.[0-9]{4})|^28\\.02\\.([0-9]{4}))|(30\\.(0[469]|11)(\\.[0-9]{4})|^[0-2][0-9]\\.(0[13578]|1[02])(\\.[0-9]{4})))$', 'gm')
const str = `26.01.2020
10.12.2020
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}