re = /((^3\.(0[13578]|1[2])(\.[0-9]{4})|^28\.02\.([0-9]{4}))|(30\.(0[469]|11)(\.[0-9]{4})|^[0-2][0-9]\.(0[13578]|1[02])(\.[0-9]{4})))$/m
str = '26.01.2020
10.12.2020
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end