#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)class="?Mso|style="[^ ]*\bmso-"
Local $sString = "<b style='mso-bidi-font-weight:normal'><span" & @CRLF & _
"style='font-size:11.0pt;line-height:107%;font-family:"Calibri",sans-serif;" & @CRLF & _
"mso-ascii-theme-font:minor-latin;mso-fareast-font-family:Calibri;mso-fareast-theme-font:" & @CRLF & _
"minor-latin;mso-hansi-theme-font:minor-latin;mso-bidi-font-family:"Times New Roman";" & @CRLF & _
"mso-bidi-theme-font:minor-bidi;mso-ansi-language:EN-US;mso-fareast-language:" & @CRLF & _
"EN-US;mso-bidi-language:AR-SA'>Update translations after adding </span></b>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")