# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"class=\"?Mso|style=\"[^ ]*\bmso-"
test_str = ("<b style='mso-bidi-font-weight:normal'><span\n"
"style='font-size:11.0pt;line-height:107%;font-family:\"Calibri\",sans-serif;\n"
"mso-ascii-theme-font:minor-latin;mso-fareast-font-family:Calibri;mso-fareast-theme-font:\n"
"minor-latin;mso-hansi-theme-font:minor-latin;mso-bidi-font-family:\"Times New Roman\";\n"
"mso-bidi-theme-font:minor-bidi;mso-ansi-language:EN-US;mso-fareast-language:\n"
"EN-US;mso-bidi-language:AR-SA'>Update translations after adding </span></b>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.