import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "class=\"?Mso|style=\"[^ ]*\\bmso-";
final String string = "<b style='mso-bidi-font-weight:normal'><span\n"
+ "style='font-size:11.0pt;line-height:107%;font-family:\"Calibri\",sans-serif;\n"
+ "mso-ascii-theme-font:minor-latin;mso-fareast-font-family:Calibri;mso-fareast-theme-font:\n"
+ "minor-latin;mso-hansi-theme-font:minor-latin;mso-bidi-font-family:\"Times New Roman\";\n"
+ "mso-bidi-theme-font:minor-bidi;mso-ansi-language:EN-US;mso-fareast-language:\n"
+ "EN-US;mso-bidi-language:AR-SA'>Update translations after adding </span></b>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}