package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*-\s*`)
var str = `I'm hope-less and can -not solve this pro- blem on my own. Wo - uld you help me?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}