re = /\s*-\s*/m
str = 'I\'m hope-less and can -not solve this pro- blem on my own. Wo - uld you help me?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end