$re = '/\s*-\s*/m';
$str = 'I\'m hope-less and can -not solve this pro- blem on my own. Wo - uld you help me?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);