package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(([a-z\-]+)(?:\.com|\.vn|\.co.uk))`)
var str = `http://www.dantri.vn/baiviet/home.rss`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}