re = /(([a-z\-]+)(?:\.com|\.vn|\.co.uk))/m
str = 'http://www.dantri.vn/baiviet/home.rss'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end