$re = '/(([a-z\-]+)(?:\.com|\.vn|\.co.uk))/m';
$str = 'http://www.dantri.vn/baiviet/home.rss';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);