$re = '/<command.+(?:valid|executed)="(?<val>[^"]+)"\s*\/>/m';
$str = '<command valid="true" />
<command name="LoadDocument" executed="true" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);