re = /<command.+(?:valid|executed)="(?<val>[^"]+)"\s*\/>/m
str = '<command valid="true" />
<command name="LoadDocument" executed="true" />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end