import re
regex = re.compile(r"(?:(?!/)[\S])*-(?:(?!/)[\S])*", flags=re.MULTILINE)
test_str = (">>> string_1 = 'variety.com/2017/biz/news/tax-march-donald-trump-protest-1202031487/'\n"
">>> string_2 = 'variety.com/2017/biz/the/life/of/madam/green/news/tax-march-donald-trump-protest-1202031487/'\n"
">>> string_3 = 'variety.com/2017/biz/the/life/of/news/tax-march-donald-trump-protest-1202031487/the/days/of/our/lives'\n"
"Desire")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")