import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[/-]+(?<key>\\S+?))|(?:\"\"[/-]+(?<key>.+?)\"\")|(?:'[/-]+(?<key>.+?)')|(?:\"\"(?<value>.+?)\"\")|(?:'(?<value>.+?)')|(?<value>\\S+)";
final String string = "command.exe \"/c\" '/f' --i file1.txt 'new 2.txt' -o \"new file.txt\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}