$re = '/(?:[/-]+(?<key>\S+?))|(?:""[/-]+(?<key>.+?)"")|(?:\'[/-]+(?<key>.+?)\')|(?:""(?<value>.+?)"")|(?:\'(?<value>.+?)\')|(?<value>\S+)/m';
$str = 'command.exe "/c" \'/f\' --i file1.txt \'new 2.txt\' -o "new file.txt"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);