import re
regex = re.compile(r"(?:[/-]+(?<key>\S+?))|(?:\"\"[/-]+(?<key>.+?)\"\")|(?:'[/-]+(?<key>.+?)')|(?:\"\"(?<value>.+?)\"\")|(?:'(?<value>.+?)')|(?<value>\S+)", flags=re.MULTILINE)
test_str = "command.exe \"/c\" '/f' --i file1.txt 'new 2.txt' -o \"new file.txt\""
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")