#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https:\/\/(dev-|stag-|)(assets|images)\.server\.io\/v[\d]\/file\/(.*?)\/(?!(download$))"
Local $sString = "https://assets.server.io/v3/file/blt123e25b85f95497/download.jpg" & @CRLF & _
"https://images.server.io/v3/file/blt123e25b85f95497/download" & @CRLF & _
"https://images.server.io/v3/file/blt123e25b85f95497/random.jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")