const regex = /https:\/\/(dev-|stag-|)(assets|images)\.server\.io\/v[\d]\/file\/(.*?)\/(?!(download$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/(dev-|stag-|)(assets|images)\\.server\\.io\\\/v[\\d]\\\/file\\\/(.*?)\\\/(?!(download$))', 'gm')
const str = `https://assets.server.io/v3/file/blt123e25b85f95497/download.jpg
https://images.server.io/v3/file/blt123e25b85f95497/download
https://images.server.io/v3/file/blt123e25b85f95497/random.jpg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}