$re = '/https:\/\/(dev-|stag-|)(assets|images)\.server\.io\/v[\d]\/file\/(.*?)\/(?!(download$))/m';
$str = 'https://assets.server.io/v3/file/blt123e25b85f95497/download.jpg
https://images.server.io/v3/file/blt123e25b85f95497/download
https://images.server.io/v3/file/blt123e25b85f95497/random.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);