use strict;
my $str = ' the man in the land ofo ';
my $regex = qr/^\s+|\s+$|\s+(?=\s)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";