re = /^\s+|\s+$|\s+(?=\s)/m
str = ' the man in the land ofo '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result