using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[url(?|]((https?://[^[]+))|(?:=""(https?://[^""]+)"")](.+?))\[/url]";
string substitution = @"<a href=\""$1\"">$2</a>";
string input = @"[URL]www.no.http.example.com[/URL]
[url]https://any.com/any[/url]
[url=""nourl""]nourl[/url]
[URL=""https://any.com/any?any=333""]text text[/URL]
[url=""http://www.emptyTEXT.com""][/url]
[url]http://www.any.com/any?any=44#sss[/url]";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}