import re
regex = re.compile(r"\[url(?|]((https?://[^[]+))|(?:=\"(https?://[^\"]+)\")](.+?))\[/url]", flags=re.IGNORECASE)
test_str = ("[URL]www.no.http.example.com[/URL]\n"
"[url]https://any.com/any[/url]\n"
"[url=\"nourl\"]nourl[/url]\n"
"[URL=\"https://any.com/any?any=333\"]text text[/URL]\n"
"[url=\"http://www.emptyTEXT.com\"][/url]\n"
"[url]http://www.any.com/any?any=44#sss[/url]")
subst = "<a href=\\\"$1\\\">$2</a>"
result = regex.sub(subst, test_str)
if result:
print(result)