package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\[url(?|]((https?://[^[]+))|(?:="(https?://[^"]+)")](.+?))\[/url]`)
var str = `[URL]www.no.http.example.com[/URL]
[url]https://any.com/any[/url]
[url="nourl"]nourl[/url]
[URL="https://any.com/any?any=333"]text text[/URL]
[url="http://www.emptyTEXT.com"][/url]
[url]http://www.any.com/any?any=44#sss[/url]`
var substitution = "<a href=\"$1\">$2</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}