const regex = /"text":"*(.*?)", "/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"text":"*(.*?)", "', 'gm')
const str = `{ "translations": [ { "text": "Столкновение с астероидом принесло с собой смертельную угрозу, известную как \\"Синбо\\", заставившую человечество отступить на землю, отвоеванную у моря. Единственный луч надежды - это устройство, которое может бороться с Синбо, называемым \\"Механическим Божественным Генералом\\".", "detectedLanguageCode": "en" } ] }`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}