// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"text":"*(.*?)", ""#).unwrap();
let string = "{ \"translations\": [ { \"text\": \"Столкновение с астероидом принесло с собой смертельную угрозу, известную как \\\"Синбо\\\", заставившую человечество отступить на землю, отвоеванную у моря. Единственный луч надежды - это устройство, которое может бороться с Синбо, называемым \\\"Механическим Божественным Генералом\\\".\", \"detectedLanguageCode\": \"en\" } ] }";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}